Jump to content
Sign in to follow this  

"this software is incompatible with your location" message

Recommended Posts

Hello all,


im building my first DVR system for my security cams. I bought a GV800-A card and have been having ALOT of trouble with it.


2 weeks ago. I finally build the system and installed the drivers and software. when launching the app i get the message. ""this software is incompatible with your location" and then the program does not launch. I tried installing on both XP and Win7. Had the same results. So i contacted Geovision support.. long story short they said it was defective and i RMAed it.


1 week ago. I got the new card and popped it in my machine and the same message came up again! so i uninstalled the software and the drivers and restarted.. amazingly it worked after that "ONCE" and never again. I got into the quad view display mode. I shut the computer down and next time i launched the app it did the same thing with the same message.. very frustrating!


Present time. So i called Geovision back and spoke with someone named "Del" some indian guy from the sounds of it. And he asked me some questions and the final question was "is your machine a intel or amd. I said it was AMD and he said that was the problem and it is not a supported cpu "Wtf? seriously?" So luckly i had a P4 3.4ghz cpu/mobo combo sitting around so i popped it in my case and reformatted and installed drivers/app and im still getting that error message!!!


im getting very frustrated and have spent hours upon hours trying to troubleshoot.. a weird thing i found is if i uninstall my drivers it launches much further into the app but then it says cannot find keypro. and then as soon as i install the drivers it halts at the original error message.


i have scoured google and it seems geovision has no answers for me.. im at a road block.. if anyone has any idea or tips or knows about this i would really appericate some help. ive also used version 8.33 and downloaded 8.4 with the same results.. it seems to be a driver problem but ive tried multiple drivers from multiple sources. to no avail.


please help!

Share this post

Link to post
Share on other sites

Every time I've come across this error I've uninstalled the software, removed the installation directory and reinstalled. Might also check and make sure the card is getting power and seated in the slot well.

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this