Jump to content

Dahua VTO2000A, SIP Firmware and Asterisk

Recommended Posts

I got help from riogrande75 (thanks a lot by the way !) on the german forum, but I wanted to share the experience here as well.

The new VTO2202F-P (or VTO4202F-P) is delivered with a firmware which is compatible with the SIP Server on the Fritzbox.

It is now much easier to make the Fritz!Fon ring when someone rings the VTO (you just have to use the SIP server on the Fritzbox)

However this is not working well with the VTH. It is possible to connect the VTH to the Fritzbox SIP Server (using some hack) but we still won't have any video this way.

So either:

  • use the VTO SIP Server and enjoy the full video experience with the VTH
  • use the Fritzbox SIP Server and enjoy the voice experience with the Fritz!Fon, and forget about the VTH

It seems to be possible to have both, but then we have to use an Asterix server and given the report from this thread, it seems to be quite challenging.

Has anyone succeeded in having working Fritz!Fon and VTH (including video) ?

  • Thanks 1

Share this post

Link to post
Share on other sites

On 3/12/2019 at 2:42 AM, riogrande75 said:

According to the install file, yes:

root@vlinux3:~/Dahua-Firmware-Mod-Kit/General_VTOXXX_Eng_P_16M_SIP_V4.000.0000000.5.R.20181030.bin.extracted# cat Install
   "Commands" : [
      "burn dm365_ubl_boot_16M.bin.img bootloader",
      "burn custom-x.cramfs.img custom",
      "burn pd-x.cramfs.img pd",
      "burn kernel-x.cramfs.img kernel",
      "burn romfs-x.cramfs.img rootfs",
      "burn user-x.cramfs.img user",
      "burn web-x.cramfs.img web",
      "burn data-x.cramfs.img data",
      "burn gui-x.cramfs.img gui",
      "burn pcm-x.cramfs.img pcm"
   "Devices" : [
      [ "VTO1210A-X", "1.00" ],
      [ "VTO1210B-X", "1.00" ],
      [ "VTO1210C-X", "1.00" ],
      [ "VTO1220A", "1.00" ],
      [ "VTO1220B", "1.00" ],
      [ "VTO6110B", "1.00" ],
      [ "VTO6000C", "1.00" ], <<<<<<<<<<<<<<<<<<
      [ "VTO6100C", "1.00" ],
      [ "VTO6100C", "1.10" ],
      [ "VTO6100C", "1.20" ],
      [ "VTO6210B", "1.00" ],
      [ "VTO6210B", "1.10" ],
      [ "VTO2000A", "1.00" ],
      [ "VTO2000A", "1.10" ],
      [ "VTO2000A", "1.20" ]
   "Vendor" : "General"


Hello everyone, I am doing tests with a VTO6210BW equipment and a GXV3140 phone, I saw that there are some that use that configuration but I cannot find the updated forms.
Most of the links no longer exist.
If someone can help me?
And on the other hand, I need to lower the resolution of the video but I cannot access the configuration file.

Is there any other way to change the video stream to "extra" (other than via the config file)?


Share this post

Link to post
Share on other sites

Hello everyone,

I'm trying to upgrade a VTO (3211D) using files from here https://www.ip-phone-forum.de/threads/dahua-vto-vth-firmware-link-sammlung-anleitungen.305121/

My current version is 3.20.9999000.0.R

1st trial try is on this one


But I keep getting upgrade fail at 50%
Thanks to the advice I found on this topic:
I tried with congiftool5.0 or VDPconfig or configtool 3.2
I tried with the zip file that I renamed .zip.bin, or the main .bin file inside the .zip
I tried to change port tcp 37777 to 3800 with the web service but after reboot, VTO goes back to 37777, not sure why. I didn't see how to change port from configtool
I tried older firmwares also
But it keeps failing
What am I missing ?

Share this post

Link to post
Share on other sites

will this work on a NON SIP factory unit VTO2000A-C? version ?( without SIP) ?

Is there FW also for the screen ?

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now