Jump to content
Sign in to follow this  

Dahua XVR5232AN-X - how to replace NAND flash - stuck on message System startup

Recommended Posts

Dahua XVR5232AN-X -bad blocks appeared on flash. I tried to clone old flash  F50L1G41A to new one. But xvr stuck on message "System startup".

Then I flashed the factory flash XVR7x16-X (and a couple of others) - the result is the same.
In the program, when flashing the firmware, I tried to turn on and off the Spare area programming (I also cut out these areas from the dump). The result is the same - in the console there is only "System startup".
Does anyone know how to properly replace a flush in these regs?

Share this post

Link to post
Share on other sites

a couple of days of experimentation and the correct settings for the programmer was found. I use T48 and Xgpro software.

1) the dump must contain a spare area (dump size 132MB)

2) set the settings in the program: 

bit flip permission: 1bit/512B

internal ECC: disable

spare area in the file: include spare area

And after the recorder has started, set the native serial number and MAC through the terminal

setenv ID my_serial

setenv ethaddr my_mac


Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this