Jump to content
Sign in to follow this  

Hikvision DS-2CD2032-I + ffmpeg = RTSP stream errors

Recommended Posts

Hello there,


I have recently purchased Hikvision DS-2CD2032-I (firmware version 5.2.0, English).

It is connected via gigabit TP-Link PoE switch (also recently purchased).

When stream is captured with ffmpeg (or avconv) I get occasional stream errors. The errors get worse once the camera has uptime of more than 1 day.

I noticed that after a while the loadavg on camera climbs from 4-5 to 8-10. Even loadavg 4 is a bit high to start with. My airvision camera sits at loadavg of about 0.2.

When used with UDP rtsp stream (default) it is unusable (almost every frame dropped or corrupted), when used with TCP (-rtsp_transport tcp) the stream is almost perfect until it is not.


The specific errors are following:

[h264 @ 0x20fdd20] error while decoding MB 71 13, bytestream -22
[h264 @ 0x20fdd20] concealing 6578 DC, 6578 AC, 6578 MV errors in I frame
[h264 @ 0x20fd4a0] Cannot use next picture in error concealment
[h264 @ 0x20fdd20] left block unavailable for requested intra4x4 mode -1 at 0 62
[h264 @ 0x20fee20] cabac decode of qscale diff failed at 89 48

While the errors are happening I get corrupted video...

When pinging the camera there is no packet loss.


After rebooting the camera errors go away for a while and load average hovers around 4.

I do not get any errors with my airvision camera....


The camera is used with my own python motion detection script, it basically watches second stream for motion (using OpenCV) and captures the main stream with ffmpeg.

I have tried avconv (fork of ffmpeg out of ubuntu repository) and compiled latest ffmpeg, same result.


Any ideas what can I do?

Also is there any opensource firmware for IP cameras (like open-wrt, dd-wrt, tomato, etc for routers)?

The web interface is completely useless in linux environment.

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this