Jump to content
Sign in to follow this  

AVTECH KPD 674_lost ip settings

Recommended Posts


I have avtech analog KPD 674 4 ch ,and in the ip settings when i choose static ip (192.168.*.*) with my router getaway , dns my oruter or google and default port 80 after a while ,5-6 h ,the ip changes (with no reboot in dvr and router also ) to and port change to 1024..something. I have to say that it works perfect 3 1/2 years and i din`t change anything ,also i must change when i try it to change it again , the (ip /dns /port )that the machine change it not always the same exp. /port 1024 --after 1 day port 2425 .

I know that tis crazy but i thing its the motherboard of avtech KPD674

Ι forgot to say that i change the motherboard battery but it`s not nessesery bacause i lost only the ip settings all other settings are ok

Anyone can help ?

Share this post

Link to post
Share on other sites

Hi Anastast

First I must apologise - this has turned into an essay!


Can I ask - did you install any other CCTV cameras in the weeks before this started happening?


I have had an AVTech KPD 674 (with 4 cameras covering the outside of my house) which has been working perfectly for over 4 years, but I too started having these issues this year.

I have always had the cctv accessible via port 81, and use port forwarding on my router so I can access it from elsewhere with my phone (using their EagleEyes app).

When my sister's house was broken into I gave her my old internal IP camera (Storage Options SON-IP1 I think it was) and installed it for her - it was great, having its' own internal web server.

I thought I should get a couple more for my own house so bought 2 cheap IP cameras from eBay - a SriCam and a YooSee (both about £25).

When I received these and tried to set them up I was quite disappointed for lots of reasons, the main 3 being:

1 - they do not have built-in web servers and can't be accessed from a web browser - they can ONLY be used with their phone/PC apps.

2 - they are sold as "HD 720p" - erm, no - that is true ONLY when viewing live through their phone app, the alarm emails and viewing with their PC app only show a very poor 320x240 resolution!!! Very pathetic.

3 - security (lack of!) - they do not need port forwarding to work - they communicate directly with their manufacturers servers, so does the app so the 2 are linked. That means their server in China has everybody's ip addresses/passwords for these cameras!


I thought (3) was quite a big security risk - but thousands were being sold (along with lots of other cameras/cctv systems using the same "no port forwarding needed") with no complaints logged that I could see so I thought I'd risk it and give them a go...


About a week later the same problem as yours happened to my KPD 674 cctv - I couldn't access it from my sister's house. When I got home and checked I found the ip address and port had been changed to some seemingly random numbers like yours.

I wondered how that had happened - there were no outside accesses logged.

Nobody knows the password I use to access the cctv DVR - but I suspect there must be a hidden manufacturers "back door" in the embedded Linux OS (that we do not have access to view/change) that the hackers know??

I reset the ip+port + rebooted it (in case anything dodgy in memory), and it worked again.

Exactly the same thing happened every few days over the next few weeks, and I got some warning letters from Virgin Media (my IPS) saying there was virus-like activity on my network.

After the first couple of times I started writing the numbers down to see if there was a pattern:

IP address Port: 52636 42268 34877 27602 11955

Not any pattern I could see.

The IP gateway had also been changed, and the DNS servers were always set to and


I did full scans of everything I had - no virus detected.

I can't do scans of the KPD 674 or the 2 new cameras of course, but I knew it had to be them so switched them off (I also found in some forums other users starting to get issues like them being controlled/moved remotely, apparently by an engineer at the manufacturers who then asked them how the cameras were performing!).


After a few days the same thing happened again (with the cameras off) and more Virgin Media warning letters.

This time I started using a different port number on the cctv, and changed my router port forwarding accordingly.

That was 3 months ago - and I have not had any more issues with it since then!

I changed the port number as I mentioned, but I later also changed by VM package so they sent me a new router, and I got a new ip address as well.


So the new cheap IP cameras caused my issues - wondered if your problems may also be caused by new ip cameras?


Hope this helps - it might not of course.



Share this post

Link to post
Share on other sites


i have this avtech since 2013 and worked this every day,i mention that i don`t have ip camera only analog (with bnc connected) and a change one for all this years ,i change router also and the problem still .I think that happen after 6 month i change IPS. The next thing i`m gonna do its to change the dvr.

When i figure out i let you know but i suppose that it`s the dvr motherboard

Thanks for interest

Share this post

Link to post
Share on other sites

Really not sure on this one, I would say due to the low cost of a new one or just here assignment masters uk it will be uneconomical to pay for a repair. Looking at it you have a very old analogue recorder. These new entry level units will record your analogue cameras at the higher D1

Share this post

Link to post
Share on other sites

Eagle Eye on my iPhone on Orange or O2 networks worked flawlessly on 3G, so the issue appears to be unique to Vodafone. However, Vodafone allows DVR connectivity but not video. Vodafone disabled content filtering, so I am certain it is not that....

Has anyone been able to get Eagle Eye to work on an iPhone using 3G and Vodafone?

pacman 30th anniversary

Share this post

Link to post
Share on other sites

Not so long ago, I learned about scamfighter, and now my academic life has changed. Finally, I know to whom I can delegate part of my assignments and not transfer due to grades.

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this