Jump to content

QSEE (Dahua) QC818, Failed firmware update *** FIXED ***

Recommended Posts

Hi all,


I really hope some knowledgeable person on here can help me out as I'm well and truly stuck.


My QC818 h.264 HD 8ch had firmware QSee_QC804_EngFrnSpn_NP_ShutDown_V2.616.QS01.1.R.20141201.bin applied over config tool. When the system rebooted at the end of this procedure the DVR was hanging. It was on the screen with the 8 camera grid but no mouse or remote control input worked. After a couple of minutes it restarted itself back to this same condition. If I'm quick enough and click a mouse button just after system initializing I can get a menu on screen before it locks. Other times on fewer occasions it'll display the new setup wizard followed by a continuous beep.


I've connected on over RS232 ok to it and flashed the firmware files again but leads me to the same condition of hanging console session.


Prior to firmware the DVR was fine and I so wish I'd left it alone.


Thank you all.

Edited by Guest

Share this post

Link to post
Share on other sites

QSEE support have been great so far. They sent me full firmware QSee_NVR3xxx_EngFrnSpn_NP_ShutDown_V2.616.QS01.1.R.20141201 and after applying this over RS232 (update.img) I get the same behaviour. Boot to camera grid where mouse input is locked. I cannot move the pointer or open a menu apart from a brief 1 second after system initialization.


I think firmware QSee_QC804 has something in it that my system did not like.


Have queried with QSEE that QSee_NVR3xxx is compatible.

Share this post

Link to post
Share on other sites

Well I've had some success on my own...


So I knew my device was okay prior to firmware. So this did lead me to think the issue was with the firmware I downloaded for my device from the QSEE website and what the support staff sent me.


I managed to find old firmware on the internet from another DVR rebrand General_NVR3xxx_P_V2.610.2.R.20120919 as a zip with all files needed once extracted;











Once connected over RS232 (Windows 8.1 - USB to serial lead by StarTech.com)


Putty - COM3 for me, Speed = 115200


SolarWinds TFTP Server installed and running - in the TFTP root folder the extracted files.


Break the boot with character * at correct time after switching DVR on;


Issue Commands;


setenv ipaddr ;setenv gatewayip ;setenv netmask ; setenv serverip ; saveenv




sip ; lip ; saveenv




set appauto 0 ;set dh_keyboard 0 ; saveenv




run up




let DVR reboot and interrupt at correct time with * character again


issue command;


set appauto 1 ;set dh_keyboard 1 ; saveenv








I get the one beep and presented with new setup wizard where I can control mouse and access menu




Just wish I had newer firmware but at least it's working...

Share this post

Link to post
Share on other sites

Added the PoE cameras to the built-in PoE switch and I can see activity on the PoE board. The DVR under this 'general' firmware does not detect them.


(They are all QSEE cams on http: 85 TCP looking for DHCP).


I added a camera to a PoE injector and through to a gigabit switch and the DVR can find this. It seems the built-in PoE switch is not working properly under the firmware or not issuing DHCP.


Another call to QSEE whom are looking into the firmware as adamant the one issued is the one I need...

Share this post

Link to post
Share on other sites

Okay I have salvaged my system and back up and running. I've spent countless hours and managed to resolve it myself. My advice - be very careful applying firmware and ensure you check the version you are on and have this firmware to rollback to as contingency.


As previously mentioned the firmware on the QSEE website and then the one offered by support locked my system up. It seems it's just not compatible. At one point I was nearly fobbed off with the embedded chip running the operating system was shafted and that was it for the DVR. I was able to discredit this by telling them the below;


I'd found a Dahua general firmware that had my system stable but it wasn't the correct firmware and was missing the network settings "switch" feature for the PoE built-in switch. This meant my cameras were not picked up as were not being given a DHCP address by the switch feature. I knew the cameras were good as I could take a PoE injector and hook the camera up to my normal non PoE network switch. I then run advanced IP scanner (or checked the Draytek router DHCP table) and could see the IP granted. I was then able to connect to the camera http://ipv4:85


Anyway... I had luck finding the correct firmware in the format of a bin file. QSEE host the firmware on Amazon (AWS). I found it easier to navigate the AWS page of software searching for .rar, .bin, .zip files.


https://q-see.s3.amazonaws.com/ and once the file you require (i.e. in my case for QC818: content/files/firmware/QCNVR-20130806.zip) combine the paths together. i.e. https://q-see.s3.amazonaws.com/content/files/firmware/QCNVR-20130806.zip


I extracted the zip file and had a bin file to work with that was also extracted using 7zip. The contents were copied to the TFTP root folder. (Don't worry about the install.lua file if it doesn't extract).


With the RS232 steps listed above I deviated from the "run up" step. Instead I issued commands:-


run dr


/// DVR powers off to restart /// interrupt this with *


run dw


/// DVR powers off to restart /// interrupt this with *


run dl


/// DVR powers off to restart /// interrupt this with *


run dc


/// DVR powers off to restart /// interrupt this with *


change back the settings


set appauto 1; set dh_keyboard 1 ; saveenv


Issue command





I then had my system back and was able to reconfigure it to how it was in a matter of minutes. I hope these posts help someone else and saves them a bunch of time.

Share this post

Link to post
Share on other sites

Hey @Gixer. I have the exact same problem that you had. Updated the exact same firmware and faced the boot loop issue and unresponsiveness from the NVR. QSEE customer support was not very helpful


I just got the RS232 to USB cable and going to try your method. Can you tell if there is any documentation on the RS232 commands?


appreciate your help

Share this post

Link to post
Share on other sites

Hi @don_b, not that I found but stick to the commands above and you'll recover the device just fine. I found these commands after reading how to manually extract firmware and flash it via various forums.


To everyone else that has PM'd me - apologies but I do not have the time to make a you tube guide or remotely assist.


This TFTP upgrade document may help - http://uk.dahuasecurity.com/uk/download/TFTP%20upgrade%20instructor.pdf


Good luck all!

Share this post

Link to post
Share on other sites

Just had one more question. Did you use a startech crossover /NULL modem cable RS232 USB cable like this one https://smile.amazon.com/gp/product/B008634VJY/ref=oh_aui_detailpage_o00_s00?ie=UTF8&psc=1 ??


I got a RS232 straight cable that had a male end and then realized that my QC804 also has a male on its end. I then purchased a DB9female to female adapter to connect the cable to the DVR. I could install the drivers and the computer could detect the cable but on Putty, wasn't able to get to the uboot boot screen in spite of pressing and holding the '*' key after turning on the DVR.

Share this post

Link to post
Share on other sites

Hi don_b,


I used a StarTech USB to RS232 DB9 Serial Adapter Cable M/M - ICUSB232V2


which then went into a DB9 F/F extension cable.

Share this post

Link to post
Share on other sites

Hi Guys,


I have had a Q-See QC804 NVR for quite some time and have successfully upgraded the firmware before. I had done it with a USB thumb drive and it went well.


However this time I was in a hurry and saw that you could upgrade via the web page. However I got the continuous reboots. I went to Q-See's site and saw that they had a firmware to upload to the NVR that according to the title of the file was supposed to delete the configuration file. So this was a big clue! However no matter how many times I tried to get the machine to execute the file it wouldn't work. Started to search for solutions and came upon this thread. I wasn't able to get all of the files needed, but I decided to hookup a serial cable and putty and see what was up on the console connection.



TFTP from server; our IP address is; sending through gateway

Filename 'upgrade_info_7db780a713a4.txt'.

Load address: 0x80100000

Loading: T T T

Retry count exceeded.

Failed to get info.txt



This is the output that I was seeing. Fortunately the boot ended with a linux prompt.

So it seems that a TFTP server with an upgrade info file was needed. Based upon the previous clue I started searching around in Linux for the location of the configuration file. I found one named 'Config' in /mnt/mtd. I executed the command


mv Config Config.bak


Now when the machine rebooted it did the beep and went into the new startup screen. I was able to get everything re-configured through the video output and USB mouse.


However, now the web page isn't working correctly and I can't login because it keeps telling me to "Please install Plug-Ins first". Even after installing them I still can't access the web page like I could before. There is also some brief chinese writing on the left of the screen before the login box comes up. The login is in English as well as all of the configuration screens. I never noticed the Chinese stuff before. If anybody has any ideas please let me know.


But if I can't get that working, the machine is doing what I want it to do. I use Blue iris to record 16 different cameras around my home. I use the Q-See / Dahua NVR to output 4 of the cameras to my TV screen to keep an eye on things when I am at home.


In hindsight it seems like the thing to do is to restore the unit to factory fresh first, before trying to flash new firmware. I don't know if that will prevent this, but I would highly recommend doing it first as you may have to do it in the end.



Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now