Jump to content
dan13lm

Router port forwarding for Hikvision 7608 NVR

Recommended Posts

Hi,

 

I have a Hikvision 7608 NVR and I would like to record remote cameras over the internet. I tried first to connect one camera but thje NVR does not connect. I am using an Asus RT-N18 as router and I forwarded port 8000 from the camera IP to port 8000 form internet. The site  https://canyouseeme.org/ reports that the destination IP port is open in the internet. Also telnet to port 8000 is connecting on the destination IP address.  The configuration on the NVR is to connect to the destination IP on port 8000 with admin user and password and Hikvision protocol it does not connect. Camera model is Wireless Cube IP Hikvision DS-2CD2423G0-I(W) I tried to forward ports one by one in order to connect to the camera but without sucess. 

Another question in the same context is what ports should I forward in order to access the NVR from internet.   

Any help is appreciated, I am looking forward for your feedback.

 

Best regards,

Daniel

 

 

Share this post


Link to post
Share on other sites

Hi,

And thank you for the reply, surprisingly 😮 I made it working, but for some others to help I will explain the whole picture. We are talking about 4 cameras, two Hikvision cube 2MP and 2 old Vivotek. NVR is Hikvision 7608.

Topology:

Location 1: NVR -> LAN -> Router (dynamic public  IP from my ISP) -> public internet

Location2: 4 x camera -> WIFI/LAN -> Router (dynamic public  IP from my ISP ) -> public internet

 There is one important thing, my ISP has a kind of DDNS where i registered my username with a subdomain name of a domain owned by ISP so i can resolve my ip address pinging the domain name from both ends.

- Initially I tried using upnp and forwarding upnp ports to internet. Altouhgh cameras mentioned that the ports are valid on the router this did not worked, tested with canyouseeme.org, ports were not visible as opened from the internet. After reading some posts on the internet I concluded that upnp will not work.

- In the second try, for one of the camera I disabled upnp and tried to NAT the internal IP ports 80 and 8000 to external ports 8080 and respectively 18000. This did not worked too, although in my opinion they should.

- In the third attempt I did something more intrusive, I disabled the upnp, modified the http port on the camera from 80 to 8081, server port 8000 to port 8001 and RTSP from 554 to 5541. On the router I forwarded to external port 8081 to external port 8081, port 8001 to external 8001 and RTSP port 5541 to external 5541. I did the same type of changes for the other camera (also Hikvision), I configured http port to 8082, server port to 8002 and RTSP port to 5542, forwarding each one one the router with the same number for TCP protocol. 

After configuring the camera on the NVR, including the RTSP protocol port for each camera according the camera configuration, the NVR connected to the cameras.

For the Vivotek camera I changed the http port to another number i.e. for the 3rd camera http port changed to 8083 , forwarded to external 8083.  Also I changed RTSP port, 554 to 5543 and forwarded to external 5543.  You can check if the ports are opened using the web site canyouseeme.org.

In conclusion, in order to work, it is needed to change the camera http port, Hikvision server port and RTSP port and forward each one to internet with the same number. Check if they are opened and configure the cameras using the public IP of the camera location router, specifiying each server forwarded port. Also change the RTSP port on the NVR/DVR protocol for each camera definition. I do not know how RTSP port can be changed on the NVR web interface so I did it from video interface.

Also there will be a problem when the public IP will change if I reset the router where cameras are connected, I will try to configure the camera using domain name, but I do not know if the Hikvision NVR supports this.   

I hope that this explanation is clear enough in order for other people to shorten the installation time for such a scenario as I spent a lot of time doing trial and error approach.

Disclaimer : Use this information on your own risk.

 

Best regards,

Daniel

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×